Newton icon logo

Newton

Status

Crypto Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 14:29 EST

Investigating

Crypto withdrawals have been temporarily disabled while our wallet provider investigates an issue. Withdrawals already in progress will be completed or returned to users.
Posted Feb 03, 2025 - 13:49 EST
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).