Newton icon logo

Newton

Status

An issue is casuing delayed transactions on the Ethereum Mainnet
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 15:02 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 10, 2023 - 13:55 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 10, 2023 - 13:55 EST
This incident affected: Crypto Withdrawals (All Crypto Withdrawals) and Crypto Funding (All Crypto Deposits).