Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 01, 2026 - 05:00 EST
Scheduled
Bitcoin Cash will be upgrading the Bitcoin Cash mainnet on March 1, 2026, at 5 AM EST. Users attempting deposits or withdrawals of BCH during the maintenance window may encounter delays or errors, as the network may be disrupted during the upgrade. BCH trading will not be affected.
Posted Feb 10, 2026 - 16:15 EST
This scheduled maintenance affected: Crypto Funding (Bitcoin Cash - BCH) and Crypto Withdrawals (Bitcoin Cash - BCH).