Back to newton.co
Newton
Status
Newton Application
Incident Report for
Newton
Resolved
This incident has been resolved. Crypto transfers sent during the incident period may be delayed in being credited.
Posted
Aug
28
,
2024
-
16:20
EDT
Investigating
We are currently investigating an issue preventing users from logging into the Newton application. All user funds remain safe.
Posted
Aug
28
,
2024
-
15:38
EDT
This incident affected: General (Web App, Mobile Apps).
×
Subscribe to Incident
Subscribe to updates for
Newton Application
via . You'll receive .