Newton icon logo

Newton

Status

BTC withdrawals: Intermittent service disruptions
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 04, 2022 - 20:38 EDT
Identified
Our wallet partner is currently investigating increased error rates for BTC withdrawals. Some BTC withdrawals may fail at this time. Failed withdrawals will be automatically reversed.
Posted May 04, 2022 - 17:25 EDT
This incident affected: Crypto Withdrawals (Bitcoin - BTC).