Newton icon logo

Newton

Status

Crypto Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 31, 2023 - 16:11 EDT
Investigating
Withdrawals of ATOM, USDC-XLM, XRP, HBAR, EOS, and XLM have been temporarily disabled due to an ongoing issue that is currently under active investigation. User funds remain secure during this time, and we are working diligently to restore full functionality as soon as possible. We apologize for any inconvenience this may have caused.
Posted May 29, 2023 - 23:42 EDT
This incident affected: Crypto Withdrawals (Cosmos - ATOM, Eos - EOS, Hedera Hashgraph - HBAR, Stellar - XLM, XRP).