Newton icon logo

Newton

Status

Transaction issues on Cardano blockchain

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Nov 19, 2024 - 10:42 EST

Identified

A fix has been identified by our blockchain infrastructure partner, we are monitoring for any updates.
Posted Nov 19, 2024 - 09:24 EST

Investigating

An issue has been identified with our infrastructure which interfaces with the Cardano blockchain, preventing transactions from finalizing. We are investigating with our blockchain infrastructure partners.
Posted Nov 18, 2024 - 19:15 EST
This incident affected: Crypto Withdrawals (Cardano - ADA).