Newton icon logo

Newton

Status

e-Transfer Deposits
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 09:43 EDT
Identified
Users may experience delays when using the "Request Money" method of e-Transfer deposits. All other funding methods are currently operating as usual.
Posted Apr 05, 2024 - 21:48 EDT
This incident affected: Funding (e-Transfer Deposits).