A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2025 - 15:05 EDT
Identified
We are currently experiencing an issue that's preventing new users from signing up. We are actively investigating and working to restore functionality as quickly as possible.
Posted Oct 11, 2025 - 14:38 EDT
This incident affected: General (Web App, Mobile Apps).