Newton icon logo

Newton

Status

USDC-SOL Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 01:01 EST
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 12:21 EST
Update
MATIC withdrawals on the native network have been re-enabled.
Posted Nov 18, 2022 - 11:49 EST
Update
MATIC withdrawals on the native network have been temporarily disabled. Users are able to move MATIC via the ERC-20 network.
Posted Nov 14, 2022 - 23:51 EST
Investigating
USDC funding and withdrawals on the Solana network have been temporarily disabled. Users are able to move USDC via other networks.
Posted Nov 09, 2022 - 12:07 EST
This incident affected: Crypto Withdrawals (Polygon - MATIC, USD Coin - USDC) and Crypto Funding (USD Coin - USDC).