Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2026 - 04:00 EST
Scheduled
Our verification partner will perform infrastructure maintenance on March 3, 2026. During a brief portion of this window, some users may experience intermittent errors when completing KYC verification. These issues should resolve automatically. If problems persist, please contact our support team.
Posted Jan 28, 2026 - 16:30 EST
This scheduled maintenance affected: Verifications.