Newton icon logo

Newton

Status

ATOM Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Mar 15, 2023 - 21:24 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 13:28 EDT

Identified

Users may experience delays when withdrawing ATOM to an external wallet while our wallet provider investigates an issue. ATOM withdrawals are blocked for now.
Posted Mar 15, 2023 - 11:32 EDT
This incident affected: Crypto Funding (Cosmos Network - ATOM).