Back to newton.co
Newton
Status
e-Transfers
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Nov
14
,
2024
-
13:49
EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
14
,
2024
-
13:01
EST
Investigating
E-Transfer funding and withdrawals have been temporarily disabled while we perform an update with our banking partner.
Posted
Nov
14
,
2024
-
12:32
EST
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
e-Transfers
via . You'll receive .