Back to newton.co
Newton
Status
RNDR
Incident Report for
Newton
Resolved
This incident has been resolved, and the new RENDER token is now available on the Newton platform.
Posted
Sep
09
,
2024
-
15:14
EDT
Update
RNDR deposits have been suspended as we prepare to complete the migration to RENDER.
Posted
Sep
08
,
2024
-
12:45
EDT
Update
RNDR trading has been suspended until further notice.
Posted
Jul
18
,
2024
-
23:43
EDT
Investigating
RNDR trading will be suspended tonight, July 18, 2024, at 11:00 PM ET, in preparation for the upcoming RENDER migration. Please check out our knowledge base for more information:
https://help.newton.co/hc/en-us/articles/31481416669203-We-are-migrating-RNDR-to-RENDER
Posted
Jul
18
,
2024
-
15:09
EDT
This incident affected: General (RNDR - Trading).
×
Subscribe to Incident
Subscribe to updates for
RNDR
via . You'll receive .