Back to newton.co
Newton
Status
XRP Withdrawals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Apr
07
,
2025
-
23:06
EDT
Identified
We have identified an issue with XRP withdrawals and a fix is being implemented. We appreciate your patience while we resolve this issue.
Posted
Apr
07
,
2025
-
22:21
EDT
This incident affected: Crypto Withdrawals (XRP).
×
Subscribe to Incident
Subscribe to updates for
XRP Withdrawals
via . You'll receive .