Back to newton.co
Newton
Status
Newton Signups
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Mar
30
,
2026
-
13:32
EDT
Investigating
We are investigating an issue impacting the delivery of both email verification messages for new signups as well as password reset emails. We are working to restore normal functionality as quickly as possible.
Posted
Mar
29
,
2026
-
20:45
EDT
This incident affected: Verifications.
×
Subscribe to Incident
Subscribe to updates for
Newton Signups
via . You'll receive .