Newton icon logo

Newton

Status

Etransfer degraded performance

Incident Report for Newton

Resolved

The issue has been resolved
Posted Nov 23, 2025 - 09:13 EST

Update

We've identified an issue and a fix is undergoing
Posted Nov 23, 2025 - 08:45 EST

Investigating

We’re currently experiencing an issue affecting e-Transfer deposits and withdrawals. Our team is actively investigating the cause and working to restore full functionality as quickly as possible.

We’ll continue to monitor the situation closely and provide updates as soon as more information becomes available.

Thank you for your patience and understanding.
Posted Nov 23, 2025 - 08:29 EST
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).