e-Transfer Deposits Delayed
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Jun 26, 2022 - 17:39 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2022 - 16:30 EDT
Investigating
Users may experience delays when funding with Interac e-Transfer.
Posted Jun 26, 2022 - 16:01 EDT
This incident affected: Funding (e-Transfer Deposits).