Newton icon logo

Newton

Status

Cardano (ADA) Deposits and Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 11:16 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2025 - 10:49 EST
Investigating
Deposits and withdrawals of Cardano (ADA) have been temporarily suspended while our wallet provider investigates an issue. Deposits of ADA that have recently been sent to your Newton account may be delayed. Trading remains operational as normal.
Posted Jan 13, 2025 - 10:43 EST
This incident affected: Crypto Funding (Cardano - ADA) and Crypto Withdrawals (Cardano - ADA).