Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 06, 2025 - 07:45 EDT
Scheduled
Bitcoin Cash (BCH) will undergo a mainnet upgrade on May 6th, 2025 at 12:00 UTC. The upgrade will be completed once the network’s nodes finish upgrading. During the upgrade, BCH withdrawals and deposits will be temporarily unavailable.
Posted May 05, 2025 - 10:31 EDT
This scheduled maintenance affected: Crypto Funding (Bitcoin Cash - BCH) and Crypto Withdrawals (Bitcoin Cash - BCH).