Newton icon logo

Newton

Status

Market Volatility

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 21:06 EDT

Monitoring

Market conditions are highly volatile, but all trading systems remain operational.
Posted Oct 10, 2025 - 19:52 EDT
This incident affected: Trading (Trading Engine, Limit Orders).