Newton icon logo

Newton

Status

User Verifications

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 18:15 EST

Investigating

Some users may be unable to complete photo ID verification while our verification provider investigates a service outage.
Posted Feb 04, 2026 - 15:01 EST
This incident affected: Verifications.