Back to newton.co
Newton
Status
e-Transfer Withdrawals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Nov
12
,
2024
-
23:28
EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
12
,
2024
-
23:26
EST
Investigating
We are currently investigating an issue affecting e-Transfer withdrawals.
Posted
Nov
12
,
2024
-
23:18
EST
This incident affected: Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
e-Transfer Withdrawals
via . You'll receive .