Back to newton.co
Newton
Status
Newton iOS Application
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Aug
08
,
2024
-
16:12
EDT
Investigating
We are investigating an issue resulting in the Apple App Store not having the Newton app available for download. Existing app users may be affected, and we ask that any affected users temporarily navigate to web.newton.co in their browser instead.
Posted
Aug
08
,
2024
-
11:52
EDT
This incident affected: General (Mobile Apps).
×
Subscribe to Incident
Subscribe to updates for
Newton iOS Application
via . You'll receive .