Newton icon logo

Newton

Status

Logging in and MFA

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 12:54 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2023 - 12:25 EDT

Investigating

Users may experience delays or errors when trying to login to the Newton platform due to an ongoing issue with our authentication provider. All user funds are safe, and we look to have functionality restored as soon as possible.
Posted Mar 13, 2023 - 11:39 EDT
This incident affected: General (Web App, Mobile Apps, 2FA - Account Access).