Newton icon logo

Newton

Status

LTC Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Mar 14, 2023 - 14:57 EDT

Investigating

Users may experience delays when withdrawing Litecoin to an external wallet while our wallet provider investigates an issue.
Posted Mar 14, 2023 - 10:26 EDT
This incident affected: Crypto Withdrawals (Litecoin - LTC).