Newton icon logo

Newton

Status

FTM Trading

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Mar 29, 2023 - 13:20 EDT

Investigating

We are currently experiencing an intermittent issue affecting a small percentage of FTM trades. We are currently working with our liquidity provider to resolve this, and please reach out to support if you experience a problem.
Posted Mar 01, 2023 - 14:41 EST
This incident affected: Trading (Trading Engine).