Back to newton.co
Newton
Status
LTC Withdrawals
Incident Report for
Newton
Resolved
LTC withdrawals are now operational.
Posted
Jul
07
,
2026
-
10:01
EDT
Investigating
LTC withdrawals are temporarily unavailable due to an unexpected issue with our wallet provider.
Posted
Jul
07
,
2026
-
09:14
EDT
This incident affected: Crypto Withdrawals (Litecoin - LTC).
×
Subscribe to Incident
Subscribe to updates for
LTC Withdrawals
via . You'll receive .