Newton icon logo

Newton

Status

Trading
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 23:48 EST
Update
Limit order functionality has been re-enabled for BTC, ETH, SOL, DOGE, ADA, SHIB, MATIC, LTC, DOT, BCH and USDC. Market orders remain fully functional for most assets.
Posted Nov 14, 2022 - 23:47 EST
Investigating
Trading has been temporarily been disabled for the following assets: DASH, ETC, ZEC, ALICE, QCAD, RNDR, MASK, HOT, SRM, and WBTC.
Posted Nov 11, 2022 - 12:04 EST
This incident affected: Trading (Trading Engine, Limit Orders).