Newton icon logo

Newton

Status

MATIC Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 23:51 EST
Investigating
MATIC withdrawals on the native network have been temporarily disabled. Users are able to move MATIC via the ERC-20 network.
Posted Nov 13, 2022 - 21:13 EST
This incident affected: Crypto Withdrawals (Polygon - MATIC).