Back to newton.co
Newton
Status
Solana Network
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Jul
16
,
2025
-
22:15
EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jul
16
,
2025
-
21:55
EDT
Investigating
Users may experience intermittent issues when withdrawing cryptocurrency on the Solana network while we investigate an issue with our wallet provider.
Posted
Jul
16
,
2025
-
21:11
EDT
This incident affected: Crypto Withdrawals (Solana - SOL).
×
Subscribe to Incident
Subscribe to updates for
Solana Network
via . You'll receive .